summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/synaescope/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/synaescope/Makefile.am')
-rw-r--r--noatun-plugins/synaescope/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/noatun-plugins/synaescope/Makefile.am b/noatun-plugins/synaescope/Makefile.am
new file mode 100644
index 0000000..27c35cc
--- /dev/null
+++ b/noatun-plugins/synaescope/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES= $(all_includes) $(SDL_CFLAGS)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = noatunsynaescope.la
+
+noatunsynaescope_la_SOURCES = synaescope.cpp cmodule.cpp
+noatunsynaescope_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunsynaescope_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+
+bin_PROGRAMS = noatunsynaescope.bin
+
+noatunsynaescope_bin_SOURCES = core.cpp main.cpp sdlwrap.cpp ui.cpp
+noatunsynaescope_bin_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+noatunsynaescope_bin_LDADD = $(LIB_KDEUI) -lnoatun $(SDL_LIBS)
+
+noatun_DATA = synaescope.plugin
+noatundir = $(kde_datadir)/noatun
+
+KDE_ICON = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/synaescope.pot