summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/tyler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/tyler/Makefile.am')
-rw-r--r--noatun-plugins/tyler/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/noatun-plugins/tyler/Makefile.am b/noatun-plugins/tyler/Makefile.am
new file mode 100644
index 0000000..b42b7a0
--- /dev/null
+++ b/noatun-plugins/tyler/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES= $(all_includes) $(SDL_CFLAGS)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = noatuntyler.la
+
+noatuntyler_la_SOURCES = tyler.cpp
+noatuntyler_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatuntyler_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+
+bin_PROGRAMS = noatuntyler.bin
+
+noatuntyler_bin_SOURCES = main.cpp file.cpp compute.c display.c renderer.c
+noatuntyler_bin_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+noatuntyler_bin_LDADD = $(LIB_KDECORE) -lm $(SDL_LIBS)
+
+noatun_DATA = tyler.plugin tylerstates
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/tyler.pot