summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-20 03:59:04 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-20 03:59:04 +0000
commit5379c37cfc91f24716af951dd08503f65f7575d7 (patch)
tree59288babdc8ae3bf4b529b7ced17509450f05679 /CMakeLists.txt
parent99a9c9fb9a9ce322e8b43fc101877c6a78622bca (diff)
downloadtdeartwork-5379c37cfc91f24716af951dd08503f65f7575d7.tar.gz
tdeartwork-5379c37cfc91f24716af951dd08503f65f7575d7.zip
Commit initial kdeartwork CMake support, courtesy of Golubev Alexander
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeartwork@1259766 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt91
1 files changed, 91 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..d63a4999
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,91 @@
+#################################################
+#
+# (C) 2011 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+##### general package setup #####################
+
+project( kdeartwork )
+
+set( PACKAGE kdeartwork )
+set( VERSION "3.5.13" )
+
+
+##### include essential cmake modules ###########
+
+include( FindPkgConfig )
+include( CheckIncludeFile )
+include( CheckIncludeFileCXX )
+include( CheckCXXSourceCompiles )
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff ############################
+
+option( WITH_XSCREENSAVER "Enable xscreensavers support" ON )
+option( WITH_LIBART "Enable libart support" ON )
+option( WITH_OPENGL "Enable 3D GL modes" ON )
+option( WITH_ARTS "Enable aRts support" OFF )
+
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_EMOTICONS "Build emoticons" ${BUILD_ALL} )
+option( BUILD_ICEWM_THEMES "Build icewm-themes" ${BUILD_ALL} )
+option( BUILD_ICON_THEMES "Build icon themes" ${BUILD_ALL} )
+option( BUILD_KSCREENSAVER "Build kscreensaver" ${BUILD_ALL} )
+option( BUILD_KWIN_STYLES "Build kwin styles" ${BUILD_ALL} )
+option( BUILD_KWORLDCLOCK "Build kworldclock" ${BUILD_ALL} )
+option( BUILD_SOUNDS "Build sounds" ${BUILD_ALL} )
+option( BUILD_STYLES "Build styles" ${BUILD_ALL} )
+option( BUILD_WALLPAPERS "Build wallpapers" ${BUILD_ALL} )
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+###### global compiler settings #################
+
+add_definitions(
+ -DHAVE_CONFIG_H
+)
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+
+##### kdenetwork directories ####################
+
+tde_conditional_add_subdirectory( BUILD_EMOTICONS emoticons )
+tde_conditional_add_subdirectory( BUILD_ICEWM_THEMES icewm-themes )
+tde_conditional_add_subdirectory( BUILD_ICON_THEMES IconThemes )
+tde_conditional_add_subdirectory( BUILD_KSCREENSAVER kscreensaver )
+tde_conditional_add_subdirectory( BUILD_KWIN_STYLES kwin-styles )
+tde_conditional_add_subdirectory( BUILD_KWORLDCLOCK kworldclock )
+tde_conditional_add_subdirectory( BUILD_SOUNDS sounds )
+tde_conditional_add_subdirectory( BUILD_STYLES styles )
+tde_conditional_add_subdirectory( BUILD_WALLPAPERS wallpapers )
+
+##### write configure files #####################
+
+configure_file( config.h.cmake config.h @ONLY )