summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-02-13 01:07:34 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-02-14 17:30:51 +0100
commitb588a3b46dc59f8b17f3f791f51fa6371d1d4c36 (patch)
treebf5321f1b38a083f85074e3044db60f3c3a39772 /CMakeLists.txt
parent8e3c27e717a93e9dcd0b19b97198a039c4a01461 (diff)
downloadtdeartwork-b588a3b46dc59f8b17f3f791f51fa6371d1d4c36.tar.gz
tdeartwork-b588a3b46dc59f8b17f3f791f51fa6371d1d4c36.zip
tdescreensaver: Add an option to force the installation of desktop files
for all xscreensavers, regardless of whether the corresponding XML files are currently present during the build. This is useful especially for building binary packages for distributions, so it is OFF by default. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7a7a60a910b04e9af84a1e3161d8661499de5384)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d6977ce..97fd9933 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,8 @@ tde_setup_paths( )
##### optional stuff ############################
option( WITH_XSCREENSAVER "Enable xscreensavers support" ON )
+option( WITH_ALL_INCLUDED_XSCREENSAVERS
+ "Install all included desktop files regardless of the presence of XML" OFF )
option( WITH_LIBART "Enable libart support" ON )
option( WITH_OPENGL "Enable 3D GL modes" ON )
option( WITH_ARTS "Enable aRts support" OFF )
@@ -51,6 +53,7 @@ option( WITH_ARTS "Enable aRts support" OFF )
##### options comments ##########################
# WITH_XSCREENSAVER affects tdescreensaver
+# WITH_ALL_INCLUDED_XSCREENSAVERS affects tdescreensaver
# WITH_LIBART affects tdescreensaver
# WITH_OPENGL affects tdescreensaver
# WITH_ARTS affects tdescreensaver