summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-02-13 01:07:34 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-02-13 01:10:59 +0100
commit7a7a60a910b04e9af84a1e3161d8661499de5384 (patch)
tree57f76b117dcf1116d0028f81f204f786355d55ce /CMakeLists.txt
parentd54edce264831393ab1fca3f4c2cee5baf40b2a1 (diff)
downloadtdeartwork-7a7a60a910b04e9af84a1e3161d8661499de5384.tar.gz
tdeartwork-7a7a60a910b04e9af84a1e3161d8661499de5384.zip
tdescreensaver: Add an option to force the installation of desktop files
for all xscreensavers, regardless of whether the corresponding XML files are currently present during the build. This is useful especially for building binary packages for distributions, so it is OFF by default. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9db57521..7505b53d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,8 @@ tde_setup_paths( )
##### optional stuff ############################
option( WITH_XSCREENSAVER "Enable xscreensavers support" ON )
+option( WITH_ALL_INCLUDED_XSCREENSAVERS
+ "Install all included desktop files regardless of the presence of XML" OFF )
option( WITH_LIBART "Enable libart support" ON )
option( WITH_OPENGL "Enable 3D GL modes" ON )
option( WITH_ARTS "Enable aRts support" OFF )
@@ -51,6 +53,7 @@ option( WITH_ARTS "Enable aRts support" OFF )
##### options comments ##########################
# WITH_XSCREENSAVER affects tdescreensaver
+# WITH_ALL_INCLUDED_XSCREENSAVERS affects tdescreensaver
# WITH_LIBART affects tdescreensaver
# WITH_OPENGL affects tdescreensaver
# WITH_ARTS affects tdescreensaver