summaryrefslogtreecommitdiffstats
path: root/kworldclock/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-18 00:52:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-18 00:53:32 +0200
commit1463c34d97a28247996d085a535535358afee3cf (patch)
treebf589e4ad00eaa9c570fbc91216040bd1506f7ef /kworldclock/CMakeLists.txt
parent06d1578a8726c4ed5b367d2486c9aa87631e2d61 (diff)
downloadtdeartwork-1463c34d97a28247996d085a535535358afee3cf.tar.gz
tdeartwork-1463c34d97a28247996d085a535535358afee3cf.zip
Use common rules for kworldclock themes.
Install SVG and SVGZ wallpapers. This addresses the shortcomings of the recent commit. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a37036141b3ab08fd5aba8a5ebf473e04690886d)
Diffstat (limited to 'kworldclock/CMakeLists.txt')
-rw-r--r--kworldclock/CMakeLists.txt30
1 files changed, 24 insertions, 6 deletions
diff --git a/kworldclock/CMakeLists.txt b/kworldclock/CMakeLists.txt
index a255f2da..2f359034 100644
--- a/kworldclock/CMakeLists.txt
+++ b/kworldclock/CMakeLists.txt
@@ -3,15 +3,33 @@
# (C) 2010 Serghei Amelian
# serghei (DOT) amelian (AT) gmail.com
#
+# (C) 2020 Slávek Banko
+# slavek.banko (AT) axis.cz
+#
# Improvements and feedback are welcome
#
# This file is released under GPL >= 2
#
#################################################
-add_subdirectory( alt )
-add_subdirectory( bio )
-add_subdirectory( caida )
-add_subdirectory( caida_bw )
-add_subdirectory( mggd )
-add_subdirectory( rainfall )
+file( GLOB _themes RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
+list( SORT _themes )
+
+foreach( _theme IN LISTS _themes )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_theme} AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_theme}/${_theme}.desktop )
+ file( GLOB _map_images RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${_theme}/*.jpg )
+ list( SORT _map_images )
+
+ install(
+ FILES ${_map_images}
+ DESTINATION "${DATA_INSTALL_DIR}/kworldclock/maps/${_theme}"
+ )
+
+ tde_create_translated_desktop(
+ SOURCE ${_theme}/${_theme}.desktop
+ DESTINATION "${DATA_INSTALL_DIR}/kworldclock/maps/${_theme}"
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kworldclock-themes
+ )
+ endif()
+endforeach()