summaryrefslogtreecommitdiffstats
path: root/styles/phase2/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Reher <tde@4reher.org>2021-01-21 12:51:58 -0800
committerVincent Reher <tde@4reher.org>2021-01-21 12:51:58 -0800
commit714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f (patch)
tree52972183cfadca52c1ef2185fb21741e81ab0290 /styles/phase2/CMakeLists.txt
parentf39f559fbfecb22bdfd46b07ba87ab832af2ae27 (diff)
downloadtdeartwork-714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f.tar.gz
tdeartwork-714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f.zip
Introduce new TDE widget style that scales with font DPI.feature/Phase2_style
Style is based on the 'phase' style which according to its author David Johnson, is "abandonware" (per 2020-09-24 email to Author). This initial commit is based on code developed <= 2020-07-20 and has been tested and actively used on Author's systems to date. Signed-off-by: Vincent Reher <tde@4reher.org>
Diffstat (limited to 'styles/phase2/CMakeLists.txt')
-rw-r--r--styles/phase2/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/styles/phase2/CMakeLists.txt b/styles/phase2/CMakeLists.txt
new file mode 100644
index 00000000..e2110ceb
--- /dev/null
+++ b/styles/phase2/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2021 Vincent Reher
+# tde (AT) 4reher.org
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ -DQT_PLUGIN
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+add_subdirectory( config )
+
+##### other data ################################
+
+tde_create_translated_desktop(
+ SOURCE phase2.themerc
+ DESTINATION ${DATA_INSTALL_DIR}/tdestyle/themes
+ PO_DIR style-themes
+)
+
+##### phase2style #################################
+
+set( target phase2style )
+
+set( ${target}_SRCS
+ phase2style.cpp phase2style.h shapes.h scaling.h
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdefx-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/styles
+)