summaryrefslogtreecommitdiffstats
path: root/styles/phase2/Makefile.am
diff options
context:
space:
mode:
authorVincent Reher <tde@4reher.org>2021-01-21 12:51:58 -0800
committerVincent Reher <tde@4reher.org>2021-01-21 12:51:58 -0800
commit714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f (patch)
tree52972183cfadca52c1ef2185fb21741e81ab0290 /styles/phase2/Makefile.am
parentf39f559fbfecb22bdfd46b07ba87ab832af2ae27 (diff)
downloadtdeartwork-714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f.tar.gz
tdeartwork-714ac1f0c4ca9bcb352aa90ab11c0bd294b20c2f.zip
Introduce new TDE widget style that scales with font DPI.feature/Phase2_style
Style is based on the 'phase' style which according to its author David Johnson, is "abandonware" (per 2020-09-24 email to Author). This initial commit is based on code developed <= 2020-07-20 and has been tested and actively used on Author's systems to date. Signed-off-by: Vincent Reher <tde@4reher.org>
Diffstat (limited to 'styles/phase2/Makefile.am')
-rw-r--r--styles/phase2/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/styles/phase2/Makefile.am b/styles/phase2/Makefile.am
new file mode 100644
index 00000000..f6d420e4
--- /dev/null
+++ b/styles/phase2/Makefile.am
@@ -0,0 +1,22 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes)
+
+styledir = $(kde_datadir)/tdestyle/themes
+style_DATA = phase2.themerc
+
+EXTRA_DIST = $(style_DATA)
+
+noinst_HEADERS = phase2style.h bitmaps.h shapes.h arrows.h
+
+kde_style_LTLIBRARIES = phase2style.la
+phase2style_la_SOURCES = phase2style.cpp
+phase2style_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx
+phase2style_la_LIBADD = -ltdefx -ltdecore
+phase2style_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(phase2style_la_METASOURCES)