summaryrefslogtreecommitdiffstats
path: root/kwin-styles/openlook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin-styles/openlook/Makefile.am')
-rw-r--r--kwin-styles/openlook/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kwin-styles/openlook/Makefile.am b/kwin-styles/openlook/Makefile.am
new file mode 100644
index 00000000..25ed43d0
--- /dev/null
+++ b/kwin-styles/openlook/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kwin3_openlook.la
+
+kwin3_openlook_la_SOURCES = OpenLook.cpp
+kwin3_openlook_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_openlook_la_LIBADD = -lkdecorations
+
+noinst_HEADERS = OpenLook.h
+METASOURCES = AUTO
+
+linkdir = $(kde_datadir)/kwin/
+link_DATA = openlook.desktop
+
+EXTRA_DIST = $(link_DATA)
+