summaryrefslogtreecommitdiffstats
path: root/twin-styles/riscos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin-styles/riscos/Makefile.am')
-rw-r--r--twin-styles/riscos/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/twin-styles/riscos/Makefile.am b/twin-styles/riscos/Makefile.am
new file mode 100644
index 00000000..773c341b
--- /dev/null
+++ b/twin-styles/riscos/Makefile.am
@@ -0,0 +1,39 @@
+AUTOMAKE_OPTIONS = foreign
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes)
+
+twindir = $(kde_datadir)/twin/
+twin_DATA = riscos.desktop
+
+noinst_HEADERS = AboveButton.h \
+ Button.h \
+ CloseButton.h \
+ HelpButton.h \
+ IconifyButton.h \
+ LowerButton.h \
+ Manager.h \
+ MaximiseButton.h \
+ Palette.h \
+ Static.h \
+ StickyButton.h
+
+kde_module_LTLIBRARIES = twin3_riscos.la
+twin3_riscos_la_SOURCES = AboveButton.cpp \
+ Button.cpp \
+ CloseButton.cpp \
+ HelpButton.cpp \
+ IconifyButton.cpp \
+ LowerButton.cpp \
+ Manager.cpp \
+ MaximiseButton.cpp \
+ Static.cpp \
+ StickyButton.cpp
+
+twin3_riscos_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx
+twin3_riscos_la_LIBADD = $(LIB_TDEUI) -ltdecorations
+twin3_riscos_la_METASOURCES = AUTO
+
+EXTRA_DIST = $(twin_DATA)
+