summaryrefslogtreecommitdiffstats
path: root/twin-styles/smooth-blend/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'twin-styles/smooth-blend/client/CMakeLists.txt')
-rw-r--r--twin-styles/smooth-blend/client/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/twin-styles/smooth-blend/client/CMakeLists.txt b/twin-styles/smooth-blend/client/CMakeLists.txt
new file mode 100644
index 00000000..d59126f9
--- /dev/null
+++ b/twin-styles/smooth-blend/client/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2011 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( config )
+
+add_definitions(
+ -DQT_PLUGIN
+)
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES smoothblend.desktop DESTINATION ${DATA_INSTALL_DIR}/twin )
+
+##### twin3_smoothblend ##########################
+
+tde_add_kpart( twin3_smoothblend AUTOMOC
+ SOURCES smoothblend.cc
+ LINK tdecorations-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)