summaryrefslogtreecommitdiffstats
path: root/twin-styles/smooth-blend/client/config/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin-styles/smooth-blend/client/config/Makefile.am')
-rw-r--r--twin-styles/smooth-blend/client/config/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/twin-styles/smooth-blend/client/config/Makefile.am b/twin-styles/smooth-blend/client/config/Makefile.am
new file mode 100644
index 00000000..ba5cd314
--- /dev/null
+++ b/twin-styles/smooth-blend/client/config/Makefile.am
@@ -0,0 +1,15 @@
+AUTOMAKE_OPTIONS = foreign
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = smoothblendconfig.h
+
+kde_module_LTLIBRARIES = twin_smoothblend_config.la
+twin_smoothblend_config_la_SOURCES = configdialog.ui smoothblendconfig.cc
+twin_smoothblend_config_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx
+twin_smoothblend_config_la_LIBADD = $(LIB_TDEUI)
+twin_smoothblend_config_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(twin_smoothblend_config_la_METASOURCES)