summaryrefslogtreecommitdiffstats
path: root/twin-styles/system/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin-styles/system/Makefile.am')
-rw-r--r--twin-styles/system/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/twin-styles/system/Makefile.am b/twin-styles/system/Makefile.am
new file mode 100644
index 00000000..5b401370
--- /dev/null
+++ b/twin-styles/system/Makefile.am
@@ -0,0 +1,21 @@
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = twin3_system.la
+
+twin3_system_la_SOURCES = systemclient.cpp
+twin3_system_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx
+#twin_system_la_LDFLAGS = $(all_libraries) -avoid-version -module $(KDE_RPATH) $(KDE_MT_LDFLAGS)
+twin3_system_la_LIBADD = $(LIB_TDEUI) -ltdecorations
+
+METASOURCES = AUTO
+noinst_HEADERS = systemclient.h
+
+lnkdir = $(kde_datadir)/twin/
+lnk_DATA = system.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+###KMAKE-start (don't edit or delete this block)
+
+###KMAKE-end