summaryrefslogtreecommitdiffstats
path: root/kate/data/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kate/data/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kate/data/CMakeLists.txt')
-rw-r--r--kate/data/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kate/data/CMakeLists.txt b/kate/data/CMakeLists.txt
index b81ead948..8dffa1571 100644
--- a/kate/data/CMakeLists.txt
+++ b/kate/data/CMakeLists.txt
@@ -11,8 +11,17 @@
##### other data ################################
-install( FILES kateplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
-install( FILES kate.desktop kwrite.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kateplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kate-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kate.desktop kwrite.desktop
+ PO_DIR kate-desktops
+)
+
install( FILES kateui.rc externaltools tips DESTINATION ${DATA_INSTALL_DIR}/kate )
install( FILES kwriteui.rc DESTINATION ${DATA_INSTALL_DIR}/kwrite )
install( FILES kate-2.4.upd DESTINATION ${DATA_INSTALL_DIR}/tdeconf_update )