summaryrefslogtreecommitdiffstats
path: root/kcheckpass/CMakeLists.txt
diff options
context:
space:
mode:
authorBobby Bingham <koorogi@koorogi.info>2023-03-30 21:54:25 -0500
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-06-05 12:01:42 +0900
commit61357f5f74e91ac7bc1ed8c6a5b9a0da373e22c2 (patch)
tree1b62f8f925069fb0ed2c1dd056e362f9f7d6faad /kcheckpass/CMakeLists.txt
parent5b795608e0ea643205bbd16f1ef4ab9c6187c9fe (diff)
downloadtdebase-61357f5f74e91ac7bc1ed8c6a5b9a0da373e22c2.tar.gz
tdebase-61357f5f74e91ac7bc1ed8c6a5b9a0da373e22c2.zip
kcheckpass: fix shadow support when not building tdm
1. If not building with PAM, kcheckpass relies on HAVE_SHADOW to decide whether to support shadow passwords. However, this was only set if also building tdm. Consolidate all PAM/shadow configure checks at the top level so these are always set correctly. 2. Consolidate /etc/passwd and shadow password handling The shadow password handler already completely handles /etc/passwd passwords as well, so having a separate handler for just /etc/passwd is pure code duplication. Signed-off-by: Bobby Bingham <koorogi@koorogi.info> (cherry picked from commit 8c543e26ec35237d00ec44fadda80318c386fdde)
Diffstat (limited to 'kcheckpass/CMakeLists.txt')
-rw-r--r--kcheckpass/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/kcheckpass/CMakeLists.txt b/kcheckpass/CMakeLists.txt
index 5e83ee41e..b2091e0ce 100644
--- a/kcheckpass/CMakeLists.txt
+++ b/kcheckpass/CMakeLists.txt
@@ -24,7 +24,7 @@ include_directories(
tde_add_executable( kcheckpass AUTOMOC
SOURCES
- kcheckpass.c checkpass_etcpasswd.c checkpass_pam.c
+ kcheckpass.c checkpass_pam.c
checkpass_shadow.c checkpass_osfc2passwd.c checkpass_aix.c
LINK tdefakes-shared ${CRYPT_LIBRARY} ${PAM_LIBRARY}
DESTINATION ${BIN_INSTALL_DIR}