summaryrefslogtreecommitdiffstats
path: root/kcontrol/colors/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/colors/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/colors/Makefile.am')
-rw-r--r--kcontrol/colors/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/colors/Makefile.am b/kcontrol/colors/Makefile.am
new file mode 100644
index 000000000..87f4048ef
--- /dev/null
+++ b/kcontrol/colors/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_colors.la
+
+kcm_colors_la_SOURCES = colorscm.cpp widgetcanvas.cpp
+kcm_colors_la_LDFLAGS = $(KDE_RPATH) -module -avoid-version $(all_libraries) -no-undefined
+kcm_colors_la_LIBADD = $(LIB_KDEUI) $(LIB_KIO) $(top_builddir)/kcontrol/krdb/libkrdb.la
+METASOURCES = colorscm.moc widgetcanvas.moc
+
+noinst_HEADERS = colorscm.h widgetcanvas.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmcolors.pot
+
+xdg_apps_DATA = colors.desktop