summaryrefslogtreecommitdiffstats
path: root/kcontrol/usbview/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-05-12 20:17:47 +0200
committergregory guy <gregory-tde@laposte.net>2021-05-17 23:41:50 +0200
commit1389e296969df0acf7f393b698a3a0f1fb572026 (patch)
treec974f6bebc1aefcab0658a49a6edffbe67ee6e79 /kcontrol/usbview/CMakeLists.txt
parentf9381127bb9d913a1b8d525b3feb9e2956a54b84 (diff)
downloadtdebase-1389e296969df0acf7f393b698a3a0f1fb572026.tar.gz
tdebase-1389e296969df0acf7f393b698a3a0f1fb572026.zip
Make the option -DWITH_USBIDS more visible for packagers.
Look for installed usb.ids file, if not found, default to the one provided in source. usb.ids file has been updated to Version 2021.03.31 Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kcontrol/usbview/CMakeLists.txt')
-rw-r--r--kcontrol/usbview/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/kcontrol/usbview/CMakeLists.txt b/kcontrol/usbview/CMakeLists.txt
index d16b0049e..485afcd58 100644
--- a/kcontrol/usbview/CMakeLists.txt
+++ b/kcontrol/usbview/CMakeLists.txt
@@ -28,11 +28,12 @@ tde_create_translated_desktop(
PO_DIR kcontrol-desktops
)
-if( WITH_USBIDS )
- set_property( SOURCE usbdb.cpp APPEND PROPERTY COMPILE_DEFINITIONS USBIDS_FILE="${WITH_USBIDS}" )
-else( )
- install( FILES usb.ids DESTINATION ${DATA_INSTALL_DIR} )
-endif( )
+if( USE_BUILTIN_USBIDS )
+ install(
+ FILES usb.ids
+ DESTINATION ${DATA_INSTALL_DIR}
+ )
+endif( USE_BUILTIN_USBIDS )
##### kcm_usb (module) ##########################