summaryrefslogtreecommitdiffstats
path: root/kcontrol/usbview/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/usbview/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/usbview/Makefile.am')
-rw-r--r--kcontrol/usbview/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kcontrol/usbview/Makefile.am b/kcontrol/usbview/Makefile.am
new file mode 100644
index 000000000..e43934b70
--- /dev/null
+++ b/kcontrol/usbview/Makefile.am
@@ -0,0 +1,21 @@
+kde_module_LTLIBRARIES = kcm_usb.la
+
+kcm_usb_la_SOURCES = kcmusb.cpp usbdevices.cpp usbdb.cpp
+
+kcm_usb_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_usb_la_LIBADD = $(LIB_KDEUI)
+
+AM_CPPFLAGS= $(all_includes)
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp *.i18n -o $(podir)/kcmusb.pot
+
+xdg_apps_DATA = kcmusb.desktop
+
+if install_usbids
+usb_DATA = usb.ids
+usbdir = $(kde_datadir)/kcmusb
+endif
+