summaryrefslogtreecommitdiffstats
path: root/kdeprint/kprinter/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kdeprint/kprinter/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdeprint/kprinter/Makefile.am')
-rw-r--r--kdeprint/kprinter/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kdeprint/kprinter/Makefile.am b/kdeprint/kprinter/Makefile.am
new file mode 100644
index 000000000..83c78cb91
--- /dev/null
+++ b/kdeprint/kprinter/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+INCLUDES = $(all_includes)
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kprinter.la
+
+kprinter_la_SOURCES = main.cpp printwrapper.cpp
+kprinter_la_LIBADD = -lkdeprint
+kprinter_la_LDFLAGS = -module -avoid-version $(all_libraries) $(KDE_RPATH)
+kprinter_la_METASOURCES = AUTO
+
+noinst_HEADERS = printwrapper.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kprinter.pot
+