summaryrefslogtreecommitdiffstats
path: root/kdeprint/slave/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kdeprint/slave/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdeprint/slave/Makefile.am')
-rw-r--r--kdeprint/slave/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kdeprint/slave/Makefile.am b/kdeprint/slave/Makefile.am
new file mode 100644
index 000000000..b4352d4d8
--- /dev/null
+++ b/kdeprint/slave/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+SUBDIRS = mimetypes templates
+
+INCLUDES= $(all_includes)
+
+kde_module_LTLIBRARIES = kio_print.la
+
+kio_print_la_SOURCES = kio_print.cpp
+kio_print_la_LIBADD = $(LIB_KIO) -lkdeprint
+kio_print_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = kio_print.h
+
+# Services
+servicesdir = $(kde_servicesdir)
+services_DATA = print.protocol printdb.protocol
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kio_print.pot