summaryrefslogtreecommitdiffstats
path: root/kdesktop/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-07-03 20:21:24 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-07-03 20:21:24 +0900
commit30613a47ae17d3df4ffcb17c91f939b9364846cc (patch)
tree50b2ac605975bd96c123088a0fe14bbe6186d92b /kdesktop/CMakeLists.txt
parent99059156214a0ccf6916488b0b0942e0e76bf220 (diff)
downloadtdebase-30613a47ae17d3df4ffcb17c91f939b9364846cc.tar.gz
tdebase-30613a47ae17d3df4ffcb17c91f939b9364846cc.zip
Fixed session locking at login. This resolves bug 2874.
Partially cherry picked from commit a359fef2. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'kdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/kdesktop/CMakeLists.txt b/kdesktop/CMakeLists.txt
index 45cc9e9ed..fcb84a66a 100644
--- a/kdesktop/CMakeLists.txt
+++ b/kdesktop/CMakeLists.txt
@@ -81,6 +81,8 @@ tde_add_executable( kxdglauncher
##### kdesktop (tdeinit) ########################
set( target kdesktop )
+set_source_files_properties( lockeng.cc PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
+
set( ${target}_SRCS
main.cc krootwm.cc xautolock.cc kdiconview.cc init.cc