summaryrefslogtreecommitdiffstats
path: root/kdesktop/init/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /kdesktop/init/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'kdesktop/init/CMakeLists.txt')
-rw-r--r--kdesktop/init/CMakeLists.txt21
1 files changed, 15 insertions, 6 deletions
diff --git a/kdesktop/init/CMakeLists.txt b/kdesktop/init/CMakeLists.txt
index c771e6dfb..245f84b8e 100644
--- a/kdesktop/init/CMakeLists.txt
+++ b/kdesktop/init/CMakeLists.txt
@@ -11,14 +11,23 @@
add_subdirectory( Templates )
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
directory.autostart directory.templates directory.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kdesktop )
+ DESTINATION ${DATA_INSTALL_DIR}/kdesktop
+ PO_DIR kdesktop-icons
+)
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
My_Computer My_Documents My_Network_Places Printers Trash Web_Browser
- DESTINATION ${DATA_INSTALL_DIR}/kdesktop/Desktop )
+ DESTINATION ${DATA_INSTALL_DIR}/kdesktop/Desktop
+ PO_DIR kdesktop-icons
+)
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
Home.desktop System.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kdesktop/DesktopLinks )
+ DESTINATION ${DATA_INSTALL_DIR}/kdesktop/DesktopLinks
+ PO_DIR kdesktop-icons
+)