summaryrefslogtreecommitdiffstats
path: root/kdesu/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
commitb529f046c9a64ac5fcfa60747af940cf972b3ebc (patch)
tree83c28cf7fa8fed1960ebd3924b579e7ed8c95cc6 /kdesu/CMakeLists.txt
parent6508fe4c40c60fd7a43bd3d9e19b762e10ea3f53 (diff)
downloadtdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.tar.gz
tdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'kdesu/CMakeLists.txt')
-rw-r--r--kdesu/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/kdesu/CMakeLists.txt b/kdesu/CMakeLists.txt
deleted file mode 100644
index c1fef3ba8..000000000
--- a/kdesu/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-include( CheckCSourceCompiles )
-include( CheckFunctionExists )
-
-check_c_source_compiles( "
- #define _GNU_SOURCE 1
- #include <sys/socket.h>
- int main(int argc, char *argv[]) { struct ucred red; return 0; } "
- HAVE_STRUCT_UCRED )
-
-check_c_source_runs( "
- #include <grp.h>
- #include <sys/types.h>
- int main() { struct group *grp = getgrnam(\"nogroup\"); if(grp) return 0; return 1; }"
- HAVE_NOGROUP )
-
-if( HAVE_NOGROUP )
- set( nogroup nogroup )
-else()
- check_c_source_runs("
- #include <grp.h>
- #include <sys/types.h>
- int main() { struct group *grp = getgrnam(\"nobody\"); if(grp) return 0; return 1; }"
- HAVE_NOBODY )
- if( HAVE_NOBODY )
- set( nogroup nobody )
- else()
- set( nogroup 65534 )
- endif()
-endif()
-
-check_function_exists( getpeereid HAVE_GETPEEREID )
-check_include_file( "sys/select.h" HAVE_SYS_SELECT_H )
-check_include_file( "sys/wait.h" HAVE_SYS_WAIT_H )
-
-if( WITH_SUDO_KDESU_BACKEND )
- set( DEFAULT_SUPER_USER_COMMAND sudo CACHE INTERNAL "" FORCE )
-else()
- set( DEFAULT_SUPER_USER_COMMAND su CACHE INTERNAL "" FORCE )
-endif()
-
-add_subdirectory( tdesu )
-add_subdirectory( tdesud )