summaryrefslogtreecommitdiffstats
path: root/kfind/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kfind/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfind/Makefile.am')
-rw-r--r--kfind/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/kfind/Makefile.am b/kfind/Makefile.am
new file mode 100644
index 000000000..a4f53b1b7
--- /dev/null
+++ b/kfind/Makefile.am
@@ -0,0 +1,36 @@
+#Global section
+METASOURCES = AUTO
+EXTRA_DIST = DESCRIPTION
+SUBDIRS = pics
+KDE_ICON = kfind
+# set the include path for X, qt and KDE
+INCLUDES= -I$(top_srcdir)/libkonq $(all_includes)
+
+noinst_LTLIBRARIES = libkfind_common.la
+libkfind_common_la_SOURCES = kftabdlg.cpp kfind.cpp kquery.cpp kdatecombo.cpp
+
+#This section is kfindpart
+kde_module_LTLIBRARIES = libkfindpart.la
+
+libkfindpart_la_SOURCES = kfindpart.cpp
+libkfindpart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkfindpart_la_LIBADD = libkfind_common.la $(LIB_KPARTS) $(top_builddir)/libkonq/libkonq.la
+
+noinst_HEADERS = kftabdlg.h kfind.h version.h kquery.h kdatecombo.h
+
+xdg_apps_DATA = Kfind.desktop
+
+kde_services_DATA = kfindpart.desktop
+kde_servicetypes_DATA = findpart.desktop
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kfindpart.pot
+
+#And this is for kfind
+
+bin_PROGRAMS = kfind
+kfind_SOURCES = kfwin.cpp kfinddlg.cpp main.cpp
+kfind_LDADD = libkfind_common.la $(LIB_KPARTS)
+
+# the library search path.
+kfind_LDFLAGS = $(all_libraries) $(KDE_RPATH)