summaryrefslogtreecommitdiffstats
path: root/khelpcenter/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /khelpcenter/plugins/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'khelpcenter/plugins/CMakeLists.txt')
-rw-r--r--khelpcenter/plugins/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/khelpcenter/plugins/CMakeLists.txt b/khelpcenter/plugins/CMakeLists.txt
index b76a765f1..54b806127 100644
--- a/khelpcenter/plugins/CMakeLists.txt
+++ b/khelpcenter/plugins/CMakeLists.txt
@@ -13,9 +13,12 @@ add_subdirectory( Applications )
add_subdirectory( Manpages )
# add_subdirectory( Scrollkeeper )
-install( FILES
- applets.desktop contact.desktop faq.desktop info.desktop
- links.desktop support.desktop userguide.desktop welcome.desktop
- hardwaremodules.desktop kcontrolmodules.desktop konqplugins.desktop
- tdeioslaves.desktop quickstart.desktop visualdict.desktop adminguide.desktop
- DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/plugins )
+tde_create_translated_desktop(
+ SOURCE
+ applets.desktop contact.desktop faq.desktop info.desktop
+ links.desktop support.desktop userguide.desktop welcome.desktop
+ hardwaremodules.desktop kcontrolmodules.desktop konqplugins.desktop
+ tdeioslaves.desktop quickstart.desktop visualdict.desktop adminguide.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/khelpcenter/plugins
+ PO_DIR khelpcenter-desktops
+)