summaryrefslogtreecommitdiffstats
path: root/khotkeys/app/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /khotkeys/app/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'khotkeys/app/Makefile.am')
-rw-r--r--khotkeys/app/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/khotkeys/app/Makefile.am b/khotkeys/app/Makefile.am
new file mode 100644
index 000000000..274f4b57e
--- /dev/null
+++ b/khotkeys/app/Makefile.am
@@ -0,0 +1,21 @@
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = khotkeys.la
+kde_module_LTLIBRARIES = kded_khotkeys.la
+
+khotkeys_la_SOURCES = app.cpp app.skel
+khotkeys_la_LIBADD = ../shared/libkhotkeys_shared.la $(LIB_KDECORE)
+khotkeys_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+
+kded_khotkeys_la_SOURCES = kded.cpp kded.skel
+kded_khotkeys_la_LIBADD = ../shared/libkhotkeys_shared.la $(LIB_KDECORE)
+kded_khotkeys_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+noinst_HEADERS = app.h kded.h
+
+INCLUDES = -I$(srcdir)/../shared $(all_includes)
+
+METASOURCES = AUTO
+
+servicesdir = $(kde_servicesdir)/kded
+services_DATA = khotkeys.desktop