summaryrefslogtreecommitdiffstats
path: root/kicker/applets/systemtray/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-05 07:19:55 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-05 07:19:55 +0000
commitcec8fe0157b0ab37d4919d0f04c131c11f2c9a9e (patch)
tree7063e9fe9a4205b926c181924c226bcf1112d51e /kicker/applets/systemtray/CMakeLists.txt
parent80035308b1907d75e7e09be7c8f6e14098edd533 (diff)
downloadtdebase-cec8fe0157b0ab37d4919d0f04c131c11f2c9a9e.tar.gz
tdebase-cec8fe0157b0ab37d4919d0f04c131c11f2c9a9e.zip
Fix up a few Deep Buttons glitches
Add an option to include the clock in the system tray applet Majorly enhance the Quick Launch Kicker applet git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1245129 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kicker/applets/systemtray/CMakeLists.txt')
-rw-r--r--kicker/applets/systemtray/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/kicker/applets/systemtray/CMakeLists.txt b/kicker/applets/systemtray/CMakeLists.txt
index cd3fd6348..76151db69 100644
--- a/kicker/applets/systemtray/CMakeLists.txt
+++ b/kicker/applets/systemtray/CMakeLists.txt
@@ -15,10 +15,13 @@ include_directories(
${CMAKE_SOURCE_DIR}/kicker/libkicker
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/kicker/applets/clock
+ ${CMAKE_SOURCE_DIR}/kicker/applets/clock
)
link_directories(
${TQT_LIBRARY_DIRS}
+ ${CMAKE_BINARY_DIR}/kicker/applets/clock
)
@@ -37,7 +40,7 @@ set( ${target}_SRCS
tde_add_kpart( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
- LINK kickermain-shared
+ LINK kickermain-shared clock_panelapplet-static
DESTINATION ${PLUGIN_INSTALL_DIR}
- DEPENDENCIES kicker_core-static kicker-static kicker-shared
+ DEPENDENCIES kicker_core-static kicker-static kicker-shared clock_panelapplet-shared
)