summaryrefslogtreecommitdiffstats
path: root/konqueror/about/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /konqueror/about/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'konqueror/about/CMakeLists.txt')
-rw-r--r--konqueror/about/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/konqueror/about/CMakeLists.txt b/konqueror/about/CMakeLists.txt
index 5eb9cc0f6..9d77c04be 100644
--- a/konqueror/about/CMakeLists.txt
+++ b/konqueror/about/CMakeLists.txt
@@ -23,8 +23,17 @@ link_directories(
##### other data ################################
-install( FILES konq_aboutpage.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES konqaboutpage.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE konq_aboutpage.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR konqueror-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE konqaboutpage.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR konqueror-desktops
+)
install( FILES
box-centre-konqueror.png top-right-konqueror.png