summaryrefslogtreecommitdiffstats
path: root/konqueror/quickprint/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /konqueror/quickprint/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'konqueror/quickprint/CMakeLists.txt')
-rw-r--r--konqueror/quickprint/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/konqueror/quickprint/CMakeLists.txt b/konqueror/quickprint/CMakeLists.txt
index 29bb04443..6a51ac564 100644
--- a/konqueror/quickprint/CMakeLists.txt
+++ b/konqueror/quickprint/CMakeLists.txt
@@ -9,11 +9,14 @@
#
#################################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
text-print.desktop text-html-print.desktop text-css-print.desktop
text-ada-print.desktop text-c++-print.desktop text-c++h-print.desktop
text-ch-print.desktop text-diff-print.desktop text-java-print.desktop
text-log-print.desktop text-makefile-print.desktop text-pas-print.desktop
text-perl-print.desktop text-python-print.desktop text-tcl-print.desktop
text-tex-print.desktop text-xslt-print.desktop text-xml-print.desktop
- DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus )
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+ PO_DIR konqueror-desktops
+)