summaryrefslogtreecommitdiffstats
path: root/ksysguard/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /ksysguard/gui/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ksysguard/gui/CMakeLists.txt')
-rw-r--r--ksysguard/gui/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/ksysguard/gui/CMakeLists.txt b/ksysguard/gui/CMakeLists.txt
index 7313b6b5d..504fbeb5b 100644
--- a/ksysguard/gui/CMakeLists.txt
+++ b/ksysguard/gui/CMakeLists.txt
@@ -30,10 +30,22 @@ link_directories(
##### other data ################################
-install( FILES ksysguard.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES x-ksysguard.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+tde_create_translated_desktop(
+ SOURCE ksysguard.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+ PO_DIR ksysguard-desktops
+)
+tde_create_translated_desktop(
+ SOURCE x-ksysguard.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ksysguard-desktops
+)
install( FILES ProcessTable.sgrd SystemLoad.sgrd KSysGuardApplet.xml ksysguardui.rc DESTINATION ${DATA_INSTALL_DIR}/ksysguard )
-install( FILES ksysguardapplet.desktop DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+tde_create_translated_desktop(
+ SOURCE ksysguardapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR ksysguard-desktops
+)
##### sysguard_panelapplet (module) #############