summaryrefslogtreecommitdiffstats
path: root/libkonq/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /libkonq/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'libkonq/CMakeLists.txt')
-rw-r--r--libkonq/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/libkonq/CMakeLists.txt b/libkonq/CMakeLists.txt
index 532e31d4d..9c8842785 100644
--- a/libkonq/CMakeLists.txt
+++ b/libkonq/CMakeLists.txt
@@ -48,8 +48,17 @@ install( FILES
##### other data ################################
-install( FILES directory_bookmarkbar.desktop DESTINATION ${DATA_INSTALL_DIR}/kbookmark )
-install( FILES konqpopupmenuplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE directory_bookmarkbar.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kbookmark
+ PO_DIR libkonq-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE konqpopupmenuplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR libkonq-desktops
+)
##### konq (shared lib) #########################