summaryrefslogtreecommitdiffstats
path: root/tdeprint/tdeprint_part/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
commitb529f046c9a64ac5fcfa60747af940cf972b3ebc (patch)
tree83c28cf7fa8fed1960ebd3924b579e7ed8c95cc6 /tdeprint/tdeprint_part/Makefile.am
parent6508fe4c40c60fd7a43bd3d9e19b762e10ea3f53 (diff)
downloadtdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.tar.gz
tdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/tdeprint_part/Makefile.am')
-rw-r--r--tdeprint/tdeprint_part/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tdeprint/tdeprint_part/Makefile.am b/tdeprint/tdeprint_part/Makefile.am
new file mode 100644
index 000000000..e27404a0f
--- /dev/null
+++ b/tdeprint/tdeprint_part/Makefile.am
@@ -0,0 +1,24 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+kde_module_LTLIBRARIES = libtdeprint_part.la
+
+libtdeprint_part_la_SOURCES = printpart.cpp
+libtdeprint_part_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+libtdeprint_part_la_LIBADD = -ltdeprint_management $(LIB_KPARTS)
+
+noinst_HEADERS = printpart.h
+
+METASOURCES = AUTO
+INCLUDES = $(all_includes)
+
+# service
+myservice_DATA = tdeprint_part.desktop
+myservicedir = $(kde_servicesdir)
+
+# UI file
+myrcfile_DATA = tdeprint_part.rc
+myrcfiledir = $(kde_datadir)/tdeprint_part
+
+messages: rc.cpp
+ $(EXTRACTRC) tdeprint_part.rc >> rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdeprint_part.pot