summaryrefslogtreecommitdiffstats
path: root/tdeprint/tdeprintfax/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /tdeprint/tdeprintfax/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeprint/tdeprintfax/CMakeLists.txt')
-rw-r--r--tdeprint/tdeprintfax/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tdeprint/tdeprintfax/CMakeLists.txt b/tdeprint/tdeprintfax/CMakeLists.txt
index e2ca9a90a..0aacbc02b 100644
--- a/tdeprint/tdeprintfax/CMakeLists.txt
+++ b/tdeprint/tdeprintfax/CMakeLists.txt
@@ -24,7 +24,12 @@ link_directories(
tde_install_icons( tdeprintfax )
tde_install_icons( abentry DESTINATION ${DATA_INSTALL_DIR}/tdeprintfax/icons )
-install( FILES tdeprintfax.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE tdeprintfax.desktop
+ PO_DIR tdeprint-desktops
+)
+
install( FILES tdeprintfaxui.rc faxfilters DESTINATION ${DATA_INSTALL_DIR}/tdeprintfax )
install( PROGRAMS anytops DESTINATION ${DATA_INSTALL_DIR}/tdeprintfax )