summaryrefslogtreecommitdiffstats
path: root/twin/clients/kwmtheme/cli_installer/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
commit0b6057404f65218182ab27a9483a21065ef61fca (patch)
treeb8b06dfa2deb965bebfbe131a772124e3e693a96 /twin/clients/kwmtheme/cli_installer/Makefile.am
parent43d99cc2477266cb9072e179137f0e8485370b3d (diff)
downloadtdebase-0b6057404f65218182ab27a9483a21065ef61fca.tar.gz
tdebase-0b6057404f65218182ab27a9483a21065ef61fca.zip
Rename kwin to twin (Part 2 of 2)
Diffstat (limited to 'twin/clients/kwmtheme/cli_installer/Makefile.am')
-rw-r--r--twin/clients/kwmtheme/cli_installer/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/twin/clients/kwmtheme/cli_installer/Makefile.am b/twin/clients/kwmtheme/cli_installer/Makefile.am
new file mode 100644
index 000000000..1541c1742
--- /dev/null
+++ b/twin/clients/kwmtheme/cli_installer/Makefile.am
@@ -0,0 +1,18 @@
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+####### This part is very kwmtheme specific
+# you can add here more. This one gets installed
+bin_PROGRAMS = kwmtheme
+
+# Which sources should be compiled for kwmtheme.
+kwmtheme_SOURCES = main.cpp
+
+# the library search path.
+kwmtheme_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+kwmtheme_LDADD = $(LIB_TDECORE)
+