summaryrefslogtreecommitdiffstats
path: root/twin/compton-tde/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-08-18 20:53:07 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-08-18 20:53:07 +0900
commit2bc7176522c8cb2b154894312e2687686d7885d8 (patch)
tree24bae54df326c0f4b7bd61899695b1fd6f99d137 /twin/compton-tde/CMakeLists.txt
parent1fe99ddf2ea7b62d4a0c4afc1c47d44372aa8e96 (diff)
downloadtdebase-2bc7176522c8cb2b154894312e2687686d7885d8.tar.gz
tdebase-2bc7176522c8cb2b154894312e2687686d7885d8.zip
twin compton: use libpcre2 instead of libpcre
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'twin/compton-tde/CMakeLists.txt')
-rw-r--r--twin/compton-tde/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/twin/compton-tde/CMakeLists.txt b/twin/compton-tde/CMakeLists.txt
index d432b533f..8e29dd12c 100644
--- a/twin/compton-tde/CMakeLists.txt
+++ b/twin/compton-tde/CMakeLists.txt
@@ -24,7 +24,7 @@ include_directories(
${XINERAMA_INCLUDE_DIRS}
${XRANDR_INCLUDE_DIRS}
${GL_INCLUDE_DIRS}
- ${LIBPCRE_INCLUDE_DIRS}
+ ${LIBPCRE2_INCLUDE_DIRS}
)
link_directories(
@@ -33,7 +33,7 @@ link_directories(
${XINERAMA_LIBRARY_DIRS}
${XRANDR_LIBRARY_DIRS}
${GL_LIBRARY_DIRS}
- ${LIBPCRE_LIBRARY_DIRS}
+ ${LIBPCRE2_LIBRARY_DIRS}
)
@@ -46,8 +46,8 @@ link_directories(
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_GLSL
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_FBO
-# WITH_PCRE -> CONFIG_REGEX_PCRE
-# WITH_PCRE -> CONFIG_REGEX_PCRE_JIT
+# WITH_PCRE2 -> CONFIG_REGEX_PCRE2
+# WITH_PCRE2 -> CONFIG_REGEX_PCRE2_JIT
# WITH_LIBCONFIG -> CONFIG_LIBCONFIG
#
# HAVE_LIBCONFIG_OLD_API -> CONFIG_LIBCONFIG_LEGACY (set up in compton_config.h)
@@ -90,10 +90,10 @@ if( WITH_XRANDR )
list( APPEND compton_LIBRARIES ${XRANDR_LIBRARIES} )
endif( )
-if( WITH_PCRE )
- set( CONFIG_REGEX_PCRE ${WITH_PCRE} )
- set( CONFIG_REGEX_PCRE_JIT ${WITH_PCRE} )
- list( APPEND compton_LIBRARIES ${LIBPCRE_LIBRARIES} )
+if( WITH_PCRE2 )
+ set( CONFIG_REGEX_PCRE2 ${WITH_PCRE2} )
+ set( CONFIG_REGEX_PCRE2_JIT ${WITH_PCRE2} )
+ list( APPEND compton_LIBRARIES ${LIBPCRE2_LIBRARIES} )
endif( )
configure_file( compton_config.h.cmake compton_config.h )