summaryrefslogtreecommitdiffstats
path: root/twin/kcmtwin/twinoptions/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
commit0b6057404f65218182ab27a9483a21065ef61fca (patch)
treeb8b06dfa2deb965bebfbe131a772124e3e693a96 /twin/kcmtwin/twinoptions/CMakeLists.txt
parent43d99cc2477266cb9072e179137f0e8485370b3d (diff)
downloadtdebase-0b6057404f65218182ab27a9483a21065ef61fca.tar.gz
tdebase-0b6057404f65218182ab27a9483a21065ef61fca.zip
Rename kwin to twin (Part 2 of 2)
Diffstat (limited to 'twin/kcmtwin/twinoptions/CMakeLists.txt')
-rw-r--r--twin/kcmtwin/twinoptions/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/twin/kcmtwin/twinoptions/CMakeLists.txt b/twin/kcmtwin/twinoptions/CMakeLists.txt
new file mode 100644
index 000000000..591883e21
--- /dev/null
+++ b/twin/kcmtwin/twinoptions/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES twinoptions.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+install( FILES
+ twinactions.desktop twinadvanced.desktop twinfocus.desktop
+ twinmoving.desktop twintranslucency.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+
+
+##### kcm_twinoptions (module) ##################
+
+tde_add_kpart( kcm_twinoptions AUTOMOC
+ SOURCES windows.cpp mouse.cpp main.cpp
+ LINK tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)