summaryrefslogtreecommitdiffstats
path: root/dcopperl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'dcopperl/Makefile.PL')
-rw-r--r--dcopperl/Makefile.PL24
1 files changed, 12 insertions, 12 deletions
diff --git a/dcopperl/Makefile.PL b/dcopperl/Makefile.PL
index 66121e65..fbd26f0a 100644
--- a/dcopperl/Makefile.PL
+++ b/dcopperl/Makefile.PL
@@ -4,30 +4,30 @@ use Config;
# the contents of the Makefile that is written.
print "Trying to find some configuration information...\n";
-my $kde_dirs = $ENV{TDEDIRS} || '/usr/local/kde';
-my $qt_dir = $ENV{QTDIR} || '/usr/lib/qt';
-my $kde_inc = "$kde_dirs/include";
-my $kde_lib = "$kde_dirs/lib";
+my $tde_dirs = $ENV{TDEDIRS} || '/opt/trinity';
+my $qt_dir = $ENV{QTDIR} || '/opt/trinity/lib';
+my $tde_inc = "$tde_dirs/include";
+my $tde_lib = "$tde_dirs/lib";
my $qt_inc = "$qt_dir/include";
my $qt_lib = "$qt_dir/lib";
-$kde_inc = undef unless -f "$kde_inc/dcopclient.h";
-$kde_lib = undef unless -f "$kde_lib/libDCOP.$Config{dlext}";
+$tde_inc = undef unless -f "$tde_inc/dcopclient.h";
+$tde_lib = undef unless -f "$tde_lib/libDCOP.$Config{dlext}";
$qt_dir = undef unless -f "$qt_inc/qglobal.h";
print "Path to Qt headers? [$qt_inc]: ";
chomp $input, $qt_inc = $input if (($input = <>) =~ /\S/);
print "Path to Qt libraries? [$qt_lib]: ";
chomp $input, $qt_lib = $input if (($input = <>) =~ /\S/);
-print "Path to KDE headers? [$kde_inc]: ";
-chomp $input, $kde_inc = $input if (($input = <>) =~ /\S/);
-print "Path to KDE libraries? [$kde_lib]: ";
-chomp $input, $kde_lib = $input if (($input = <>) =~ /\S/);
+print "Path to TDE headers? [$tde_inc]: ";
+chomp $input, $tde_inc = $input if (($input = <>) =~ /\S/);
+print "Path to TDE libraries? [$tde_lib]: ";
+chomp $input, $tde_lib = $input if (($input = <>) =~ /\S/);
WriteMakefile(
NAME => 'DCOP',
VERSION_FROM => 'DCOP.pm',
- INC => "-I$qt_inc -I$kde_inc",
- LIBS => "-L$qt_lib -ltqt-mt -L$kde_lib -ltdecore -lDCOP",
+ INC => "-I$qt_inc -I$tde_inc -I/usr/include/tqt",
+ LIBS => "-L$qt_lib -ltqt-mt -L$tde_lib -ltdecore -lDCOP",
XS => {'DCOP.xs' => 'DCOP.cpp'},
XSOPT => '-C++',
CCFLAGS => '-x c++',