summaryrefslogtreecommitdiffstats
path: root/korundum/rubylib/rbkconfig_compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'korundum/rubylib/rbkconfig_compiler/Makefile.am')
-rw-r--r--korundum/rubylib/rbkconfig_compiler/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/korundum/rubylib/rbkconfig_compiler/Makefile.am b/korundum/rubylib/rbkconfig_compiler/Makefile.am
deleted file mode 100644
index 276e32f7..00000000
--- a/korundum/rubylib/rbkconfig_compiler/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-SUBDIRS = . tests
-
-RBUIC=rbuic
-
-.ui.rb:
- $(RBUIC) -tr ${UIC_TR} -kde $*.ui -o $@
-
-exampleprefs_base.rb: $(srcdir)/example.kcfg rbkconfig_compiler $(srcdir)/exampleprefs_base.kcfgc
- ./rbkconfig_compiler $(srcdir)/example.kcfg $(srcdir)/exampleprefs_base.kcfgc
-
-AM_CPPFLAGS = -I$(top_srcdir)/tdecore -I$(top_srcdir) $(all_includes)
-
-bin_PROGRAMS = rbkconfig_compiler
-
-rbkconfig_compiler_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
-rbkconfig_compiler_LDADD = $(LIB_TDECORE)
-rbkconfig_compiler_SOURCES = rbkconfig_compiler.cpp
-
-METASOURCES = AUTO
-
-TESTFILES = test1.kcfg test2.kcfg test3.kcfg test4.kcfg test5.kcfg
-
-check-local:
- for i in $(TESTFILES); \
- do xmllint --noout --schema $(srcdir)/kcfg.xsd $(srcdir)/tests/$$i; \
- perl $(top_srcdir)/korundum/rubylib/rbkconfig_compiler/checkkcfg.pl \
- $(top_srcdir)/korundum/rubylib/rbkconfig_compiler/tests/$$i; done
-