summaryrefslogtreecommitdiffstats
path: root/src/libtdeobex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libtdeobex/CMakeLists.txt')
-rw-r--r--src/libtdeobex/CMakeLists.txt23
1 files changed, 7 insertions, 16 deletions
diff --git a/src/libtdeobex/CMakeLists.txt b/src/libtdeobex/CMakeLists.txt
index b4323c8..3c6bd51 100644
--- a/src/libtdeobex/CMakeLists.txt
+++ b/src/libtdeobex/CMakeLists.txt
@@ -12,19 +12,6 @@
project( libtdeobex )
set(LIBRARY_VERSION 0.0.1)
-# include( ConfigureChecks.cmake )
-foreach( f ${TQT_LIBRARIES} )
- if( ${f} STREQUAL "tqt-mt" )
- set(TQUI_LIBRARIES "tqui" CACHE TYPE STRING FORCE)
- endif()
- if( ${f} STREQUAL "qt-mt" )
- set(TQUI_LIBRARIES "qui" CACHE TYPE STRING FORCE)
- endif()
-endforeach()
-
-# import required
-#tde_import( lib... )
-
add_subdirectory( interfaces )
include_directories(
@@ -42,8 +29,10 @@ link_directories(
${DBUS_TQT_LIBRARY_DIRS}
)
+
##### headers ###################################
# implementations
+
install(
FILES obexobjectmanagerImpl.h
DESTINATION ${INCLUDE_INSTALL_DIR}/tdeobex )
@@ -54,14 +43,16 @@ set( ${target}_SRCS obexobjectmanagerImpl.cpp )
##### tdeobex (shared) ###########################
-# set( KDE3_DCOPIDL_EXECUTABLE ${KDE3_DCOPIDLNG_EXECUTABLE} )
+
tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION ${LIBRARY_VERSION}
DEPENDS obexinterfaces-static
- LINK ${DBUS_TQT_LIBRARIES} tdeparts-shared obexinterfaces-static ${TQUI_LIBRARIES}
+ LINK ${DBUS_TQT_LIBRARIES} tdeparts-shared obexinterfaces-static ${TQTQUI_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)
-
+
+
##### install import cmake modules ###############
+
tde_install_export( )