summaryrefslogtreecommitdiffstats
path: root/kbruch/testcases/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce599e4f9f94b4eb00c1b5edb85bce5431ab3df2 (patch)
treed3bb9f5d25a2dc09ca81adecf39621d871534297 /kbruch/testcases/Makefile.am
downloadtdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.tar.gz
tdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeedu@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kbruch/testcases/Makefile.am')
-rw-r--r--kbruch/testcases/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/kbruch/testcases/Makefile.am b/kbruch/testcases/Makefile.am
new file mode 100644
index 00000000..5e9e8950
--- /dev/null
+++ b/kbruch/testcases/Makefile.am
@@ -0,0 +1,13 @@
+check_PROGRAMS = kbruch_test
+
+kbruch_test_SOURCES = task.cpp ratio.cpp ratio_test.cpp primenumber.cpp primenumber_test.cpp kbruch_test.cpp
+
+kbruch_test_LDADD = -lboost_unit_test_framework-gcc $(LIB_KDEUI)
+
+# the library search path.
+kbruch_test_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+EXTRA_DIST = primenumber.cpp primenumber.h ratio.cpp ratio.h task.cpp task.h primenumber_test.cpp ratio_test.cpp kbruch_test.cpp
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)