summaryrefslogtreecommitdiffstats
path: root/kstars/kstars/indi/webcam/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-27 16:35:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-28 13:45:47 +0200
commitaca01d5a8b7d3de53fa34696e18c91db720a5ab6 (patch)
tree6b9b83c599cc5db58df8041ca5cf812e00bbd25e /kstars/kstars/indi/webcam/CMakeLists.txt
parent88af19c041ad4f1139f6f0a35cd1a4fe2018425f (diff)
downloadtdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.tar.gz
tdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.zip
Conversion to the cmake building system.
Add includes to UI files to resolve FTBFS. Signed-off-by: gregory guy <g-gregory@gmx.fr> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit d4a1613e9f119ae68c695ab60f8d9856d1a54a52)
Diffstat (limited to 'kstars/kstars/indi/webcam/CMakeLists.txt')
-rw-r--r--kstars/kstars/indi/webcam/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/kstars/kstars/indi/webcam/CMakeLists.txt b/kstars/kstars/indi/webcam/CMakeLists.txt
new file mode 100644
index 00000000..05283d18
--- /dev/null
+++ b/kstars/kstars/indi/webcam/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### libwebcam_linux (static)
+
+if( HAVE_LINUX_VIDEODEV2_H )
+ set( V4L_SOURCES v4l2_base.cpp )
+elseif( HAVE_LINUX_VIDEODEV_H )
+ set( V4L_SOURCES v4l1_base.cpp v4l1_pwc.cpp )
+endif( )
+
+tde_add_library( libwebcam_v4l STATIC_PIC
+
+ SOURCES
+ ${V4L_SOURCES}
+ PPort.cpp
+ port.cpp
+ ccvt_c2.c
+ ccvt_misc.c
+)