summaryrefslogtreecommitdiffstats
path: root/kbackgammon/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-25 06:23:55 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:04:46 +0100
commit22eaaf46994712a7ea19be99d49c5ceb889470bd (patch)
tree6813293435ece498f1d90a99adfa5e9a49c875fe /kbackgammon/CMakeLists.txt
parentfa5d2dca53e1046fe38ac7cf0210d45ad5cc5107 (diff)
downloadtdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.tar.gz
tdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.zip
Initial cmake conversion
(cherry picked from commit c70db62d3671e524d23ac974d296eb218159b000)
Diffstat (limited to 'kbackgammon/CMakeLists.txt')
-rw-r--r--kbackgammon/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/kbackgammon/CMakeLists.txt b/kbackgammon/CMakeLists.txt
new file mode 100644
index 00000000..432239ef
--- /dev/null
+++ b/kbackgammon/CMakeLists.txt
@@ -0,0 +1,50 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( pics )
+add_subdirectory( sounds )
+add_subdirectory( icons )
+add_subdirectory( engines )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/kgame/
+ ${CMAKE_CURRENT_SOURCE_DIR}/engines
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kbackgammon (executable) ##################
+
+tde_add_executable( kbackgammon AUTOMOC
+ SOURCES main.cpp kbg.cpp kbgboard.cpp kbgtextview.cpp kbgstatus.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared tdeprint-shared
+ kbgengines-static
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+install( FILES kbackgammon.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kbackgammonui.rc eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/kbackgammon
+)