summaryrefslogtreecommitdiffstats
path: root/kfouleggs/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-10 21:25:06 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-12 15:23:06 +0200
commit87f08539f4780f52819ddb9e7d291decbc14fa6f (patch)
tree902840117702b8d2c955b33f0402e0df6446a22c /kfouleggs/CMakeLists.txt
parentbd46b20a12f3634ad167206c497bb9a050ac533c (diff)
downloadtdegames-87f08539f4780f52819ddb9e7d291decbc14fa6f.tar.gz
tdegames-87f08539f4780f52819ddb9e7d291decbc14fa6f.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a25cdc59c6302046b3121276f5a33f6b1b55a538)
Diffstat (limited to 'kfouleggs/CMakeLists.txt')
-rw-r--r--kfouleggs/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/kfouleggs/CMakeLists.txt b/kfouleggs/CMakeLists.txt
index ae0b2f69..3cbc9ca7 100644
--- a/kfouleggs/CMakeLists.txt
+++ b/kfouleggs/CMakeLists.txt
@@ -48,10 +48,10 @@ install( FILES kfouleggs.kcfg
DESTINATION ${KCFG_INSTALL_DIR}
)
-install( FILES eventsrc
+tde_create_translated_desktop(
+ SOURCE eventsrc
DESTINATION ${DATA_INSTALL_DIR}/kfouleggs
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kfouleggs-eventsrc
)
-install( FILES kfouleggs.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
+tde_create_translated_desktop( kfouleggs.desktop )