summaryrefslogtreecommitdiffstats
path: root/libtdegames/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-08-14 10:43:39 +0200
committergregory guy <gregory-tde@laposte.net>2020-08-14 11:15:28 +0200
commit83cbbc2593a54a846f4366c90a87216ecb8fbe12 (patch)
tree12e51d01e18e04e0a84e0a6baf3c761ac0af2b8e /libtdegames/CMakeLists.txt
parent5364a90fea6a26b3637b4b1f44380870652a7012 (diff)
downloadtdegames-83cbbc2593a54a846f4366c90a87216ecb8fbe12.tar.gz
tdegames-83cbbc2593a54a846f4366c90a87216ecb8fbe12.zip
Add a pkgconfig file for libtdegames.
Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'libtdegames/CMakeLists.txt')
-rw-r--r--libtdegames/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/libtdegames/CMakeLists.txt b/libtdegames/CMakeLists.txt
index d124c0c4..22eec9a9 100644
--- a/libtdegames/CMakeLists.txt
+++ b/libtdegames/CMakeLists.txt
@@ -54,3 +54,18 @@ install( FILES
##### install import cmake modules ###############
tde_install_export( )
+
+
+##### other data
+
+string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_EXEC_PREFIX ${EXEC_INSTALL_PREFIX} )
+string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_INCLUDE_DIR ${INCLUDE_INSTALL_DIR} )
+string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_LIB_DIR ${LIB_INSTALL_DIR} )
+
+configure_file( ${PROJECT_NAME}.pc.cmake ${PROJECT_NAME}.pc @ONLY )
+
+install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc
+ DESTINATION ${PKGCONFIG_INSTALL_DIR}
+)
+