summaryrefslogtreecommitdiffstats
path: root/atlantik/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'atlantik/client/CMakeLists.txt')
-rw-r--r--atlantik/client/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/atlantik/client/CMakeLists.txt b/atlantik/client/CMakeLists.txt
new file mode 100644
index 00000000..10a7e79a
--- /dev/null
+++ b/atlantik/client/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/atlantik/libatlantic
+ ${CMAKE_SOURCE_DIR}/atlantik/libatlantikui
+ ${CMAKE_SOURCE_DIR}/atlantik/libatlantikclient
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### atlantik (executable) #####################
+
+tde_add_executable( atlantik AUTOMOC
+ SOURCES atlantik.cpp configdlg.cpp event.cpp eventlogwidget.cpp main.cpp
+ monopigator.cpp selectconfiguration_widget.cpp selectgame_widget.cpp
+ selectserver_widget.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared atlantikui-shared
+ atlantikclient-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)