summaryrefslogtreecommitdiffstats
path: root/kasteroids/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kasteroids/CMakeLists.txt')
-rw-r--r--kasteroids/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/kasteroids/CMakeLists.txt b/kasteroids/CMakeLists.txt
new file mode 100644
index 00000000..ecdbdbb5
--- /dev/null
+++ b/kasteroids/CMakeLists.txt
@@ -0,0 +1,50 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( sprites )
+add_subdirectory( sounds )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/highscore
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kasteroids (executable) ###################
+
+tde_add_executable( kasteroids AUTOMOC
+ SOURCES main.cpp view.cpp ledmeter.cpp toplevel.cpp settings.kcfgc
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kasteroids )
+
+
+##### other data ################################
+install( FILES kasteroids.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kasteroidsui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kasteroids
+)
+
+install( FILES kasteroids.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)
+
+install( FILES bg.png
+ DESTINATION ${DATA_INSTALL_DIR}/kasteroids/sprites
+)