summaryrefslogtreecommitdiffstats
path: root/kbattleship/kbattleship/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kbattleship/kbattleship/Makefile.am')
-rw-r--r--kbattleship/kbattleship/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/kbattleship/kbattleship/Makefile.am b/kbattleship/kbattleship/Makefile.am
new file mode 100644
index 00000000..6c59ddd5
--- /dev/null
+++ b/kbattleship/kbattleship/Makefile.am
@@ -0,0 +1,39 @@
+SUBDIRS = dialogs . pictures sounds
+
+INCLUDES = -I$(top_srcdir)/libkdegames -I$(top_srcdir)/libkdegames/highscore $(all_includes)
+METASOURCES = AUTO
+
+bin_PROGRAMS = kbattleship
+kbattleship_SOURCES = kbaiplayer.cpp kbstrategy.cpp kbverticalstepstrategy.cpp\
+ kbdestroyshipstrategy.cpp kbhorizontalstepstrategy.cpp \
+ kbrandomshotstrategy.cpp kbdiagonalwrapstrategy.cpp \
+ kmessage.cpp kbattleshipserver.cpp kbattleshipclient.cpp \
+ kbattleshipview.cpp kgridwidget.cpp kbattlefield.cpp \
+ kchatwidget.cpp kserverdialog.cpp kclientdialog.cpp \
+ kstatdialog.cpp kbdiagonalshotstrategy.cpp \
+ konnectionhandling.cpp kship.cpp kshiplist.cpp \
+ kbchooserstrategy.cpp kbattleship.cpp main.cpp
+kbattleship_LDADD = $(LIB_KDEGAMES) ./dialogs/libkbattleshipdialogs.la $(LIB_KFILE) $(LIB_KDNSSD)
+kbattleship_COMPILE_FIRST = dialogs/infoDlg.h dialogs/chatDlg.h dialogs/connectDlg.h dialogs/serverDlg.h dialogs/statDlg.h
+kbattleship_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kbattleship_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+services_DATA = _kbattleship._tcp
+servicesdir = $(kde_datadir)/zeroconf
+
+xdg_apps_DATA = kbattleship.desktop
+
+rcdir = $(kde_datadir)/kbattleship
+rc_DATA = kbattleshipui.rc eventsrc
+
+messages: rc.cpp
+ $(EXTRACTRC) */*.ui >> rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kbattleship.pot
+
+kbattleship.o: dialogs/infoDlg.h dialogs/chatDlg.h dialogs/connectDlg.h dialogs/serverDlg.h dialogs/statDlg.h
+kbattleshipview.o: dialogs/infoDlg.h dialogs/chatDlg.h dialogs/connectDlg.h dialogs/serverDlg.h dialogs/statDlg.h
+kchatwidget.o: dialogs/chatDlg.h
+kclientdialog.o: dialogs/connectDlg.h
+kserverdialog.o: dialogs/serverDlg.h
+kstatdialog.o: dialogs/statDlg.h
+