summaryrefslogtreecommitdiffstats
path: root/kblackbox/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kblackbox/CMakeLists.txt')
-rw-r--r--kblackbox/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/kblackbox/CMakeLists.txt b/kblackbox/CMakeLists.txt
new file mode 100644
index 00000000..057c1119
--- /dev/null
+++ b/kblackbox/CMakeLists.txt
@@ -0,0 +1,40 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kblackbox (executable) ####################
+
+tde_add_executable( kblackbox AUTOMOC
+ SOURCES kbbgfx.cpp kbbgame.cpp util.cpp main.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kblackbox )
+
+
+##### other data ################################
+install( FILES kblackbox.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kblackboxui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kblackbox
+)