summaryrefslogtreecommitdiffstats
path: root/kmines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmines/Makefile.am')
-rw-r--r--kmines/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/kmines/Makefile.am b/kmines/Makefile.am
new file mode 100644
index 00000000..e49f6501
--- /dev/null
+++ b/kmines/Makefile.am
@@ -0,0 +1,66 @@
+SUBDIRS = data bitmaps solver
+INCLUDES = -I$(top_srcdir)/libkdegames -I$(top_srcdir)/libkdegames/highscore $(all_includes)
+
+KDE_CXXFLAGS = $(KDE_USE_FPIE)
+
+bin_PROGRAMS = kmines
+kmines_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(KDE_USE_PIE)
+kmines_LDADD = ./solver/libsolver.la $(LIB_KDEGAMES)
+kmines_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+kmines_SOURCES = kzoommainwindow.cpp defines.cpp highscores.cpp settings.kcfgc \
+ dialogs.cpp frame.cpp field.cpp status.cpp main.cpp
+kmines_METASOURCES = AUTO
+
+rcdir = $(kde_datadir)/kmines
+rc_DATA = kminesui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) rc.cpp *.cpp solver/*.cpp -o $(podir)/kmines.pot
+
+# for system-wide highscore file
+DESTBIN = $(DESTDIR)$(bindir)/$(bin_PROGRAMS)
+DESTHIGHSCORES = $(DESTDIR)$(HIGHSCORE_DIRECTORY)
+DESTSCORES = $(DESTDIR)$(HIGHSCORE_DIRECTORY)/$(bin_PROGRAMS).scores
+
+install-data-local:
+ @(test x$(HIGHSCORE_DIRECTORY) != x \
+ && echo "********************************************************" \
+ && echo "" \
+ && echo "This game is installed sgid \"games\" to use the" \
+ && echo "system-wide highscore file (in "$(HIGHSCORE_DIRECTORY)")." \
+ && echo "" \
+ && echo "If the system-wide highscore file does not exist, it is" \
+ && echo "created with the correct ownership and permissions. See the" \
+ && echo "INSTALL file in \"kdegames/libkdegames/highscore\" for details." \
+ && echo "" \
+ && echo "********************************************************" \
+ ) || true
+
+install-exec-hook:
+ @(test x$(HIGHSCORE_DIRECTORY) != x \
+ && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
+ || echo "Error: Could not install the game with correct permissions !!" \
+ )) || true
+
+ @(test x$(HIGHSCORE_DIRECTORY) != x \
+ && ((mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
+ && chmod 750 $(DESTHIGHSCORES)) \
+ || echo "Error: Could not create the highscore directory with correct permissions !!" \
+ )) || true
+
+ @(test x$(HIGHSCORE_DIRECTORY) != x \
+ && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
+ || echo "Error: Could not install the game with correct permissions !!" \
+ )) || true
+
+ @(test ${setgid} = true \
+ && ((chmod 2755 $(DESTBIN)) \
+ || echo "Error: Could not install the game with correct permissions !!" \
+ )) || true
+
+ @(test x$(HIGHSCORE_DIRECTORY) != x \
+ && ((touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
+ && chmod 0660 $(DESTSCORES)) \
+ || echo "Error: Could not create system-wide highscore file with correct permissions !!" \
+ )) || true
+