summaryrefslogtreecommitdiffstats
path: root/kolf/objects/poolball/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kolf/objects/poolball/CMakeLists.txt')
-rw-r--r--kolf/objects/poolball/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/kolf/objects/poolball/CMakeLists.txt b/kolf/objects/poolball/CMakeLists.txt
new file mode 100644
index 00000000..adccbef8
--- /dev/null
+++ b/kolf/objects/poolball/CMakeLists.txt
@@ -0,0 +1,29 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kolfpoolball (shared) #####################
+
+tde_add_library( kolfpoolball SHARED AUTOMOC
+ SOURCES poolball.cpp
+ LINK tdeio-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES poolball.plugin
+ DESTINATION ${DATA_INSTALL_DIR}/kolf
+)